FC2カウンター FPGAの部屋 KV260 の Ubuntu 22.04 に Kria-PYNQ のインストールを試みたが失敗した
fc2ブログ

FPGAやCPLDの話題やFPGA用のツールの話題などです。 マニアックです。 日記も書きます。

FPGAの部屋

FPGAの部屋の有用と思われるコンテンツのまとめサイトを作りました。Xilinx ISEの初心者の方には、FPGAリテラシーおよびチュートリアルのページをお勧めいたします。

KV260 の Ubuntu 22.04 に Kria-PYNQ のインストールを試みたが失敗した

ブートした KV260 用 Ubuntu 22.04 の設定を行った”の続き。

前回は、Ubuntu 22.04 の設定を行って、GUI のファイルマネージャーやテキスト・エディタを起動することができた。今回は、その KV260 の Ubuntu 22.04 に Kria-PYNQ をインストールしてみたところ失敗した。

Kria-PYNQ をやってみる3(Kira-PYNQ を git clone)”を見ながらやっていく。

Xilinx/Kria-PYNQ の 2. Install PYNQ を行う。
git clone https://github.com/Xilinx/Kria-PYNQ.git
cd Kria-PYNQ/
sudo bash install.sh

KV260_custom_platform_182_221021.png

KV260_custom_platform_183_221021.png

”Couldn't find any package by regex 'python3.8-venv'”エラーになった。
ログを示す。

ubuntu@kria:~/Kria-PYNQ$ sudo bash install.sh
[sudo] password for ubuntu: 
Installing PYNQ, this process takes around 25 minutes 
Submodule 'pynq' (https://github.com/Xilinx/PYNQ.git) registered for path 'pynq'
Cloning into '/home/ubuntu/Kria-PYNQ/pynq'...
remote: Enumerating objects: 23801, done.
remote: Counting objects: 100% (23801/23801), done.
remote: Compressing objects: 100% (8183/8183), done.
remote: Total 22919 (delta 14323), reused 22403 (delta 13828), pack-reused 0
Receiving objects: 100% (22919/22919), 130.90 MiB | 3.82 MiB/s, done.
Resolving deltas: 100% (14323/14323), completed with 376 local objects.
From https://github.com/Xilinx/PYNQ
 * branch              59515a9b5de6fad0ff0538bfc50010b16f53c9a8 -> FETCH_HEAD
Submodule path 'pynq': checked out '59515a9b5de6fad0ff0538bfc50010b16f53c9a8'
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
Executing: /tmp/apt-key-gpghome.WKV613xoqA/gpg.1.sh --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 --verbose 803DDF595EA7B6644F9B96B752150A179A9E84C9
gpg: no running Dirmngr - starting '/usr/bin/dirmngr'
gpg: waiting for the dirmngr to come up ... (5s)
gpg: connection to dirmngr established
gpg: data source: http://162.213.33.8:80
gpg: armor header: Comment: Hostname:
gpg: armor header: Version: Hockeypuck 2.1.0-184-g50f1108
gpg: pub  rsa4096/52150A179A9E84C9 2020-06-07  Launchpad PPA for Ubuntu Xilinx
gpg: key 52150A179A9E84C9: "Launchpad PPA for Ubuntu Xilinx" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
Hit:1 http://ports.ubuntu.com/ubuntu-ports jammy InRelease                     
Hit:2 http://oem.archive.canonical.com/updates jammy-limerick InRelease        
Get:3 http://ppa.launchpad.net/ubuntu-xilinx/updates/ubuntu focal InRelease [24.3 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports jammy-updates InRelease [114 kB]    
Hit:5 https://ppa.launchpadcontent.net/ubuntu-xilinx/sdk/ubuntu jammy InRelease
Get:6 http://ports.ubuntu.com/ubuntu-ports jammy-backports InRelease [99.8 kB] 
Get:7 http://ports.ubuntu.com/ubuntu-ports jammy-security InRelease [110 kB]   
Get:8 http://ppa.launchpad.net/ubuntu-xilinx/updates/ubuntu focal/main arm64 Packages [22.7 kB]
Hit:9 https://ppa.launchpadcontent.net/xilinx-apps/ppa/ubuntu jammy InRelease  
Get:10 http://ports.ubuntu.com/ubuntu-ports jammy-updates/main arm64 Packages [626 kB]
Get:11 http://ports.ubuntu.com/ubuntu-ports jammy-updates/main Translation-en [152 kB]
Get:12 http://ports.ubuntu.com/ubuntu-ports jammy-updates/main arm64 DEP-11 Metadata [93.2 kB]
Get:13 http://ports.ubuntu.com/ubuntu-ports jammy-updates/main arm64 c-n-f Metadata [9460 B]
Get:14 http://ports.ubuntu.com/ubuntu-ports jammy-updates/restricted arm64 Packages [149 kB]
Get:15 http://ports.ubuntu.com/ubuntu-ports jammy-updates/restricted Translation-en [61.3 kB]
Get:16 http://ppa.launchpad.net/ubuntu-xilinx/updates/ubuntu focal/main Translation-en [5368 B]
Get:17 http://ports.ubuntu.com/ubuntu-ports jammy-updates/universe arm64 Packages [395 kB]
Get:18 http://ports.ubuntu.com/ubuntu-ports jammy-updates/universe Translation-en [110 kB]
Get:19 http://ports.ubuntu.com/ubuntu-ports jammy-updates/universe arm64 DEP-11 Metadata [244 kB]
Get:20 http://ports.ubuntu.com/ubuntu-ports jammy-backports/universe arm64 DEP-11 Metadata [12.6 kB]
Get:21 http://ports.ubuntu.com/ubuntu-ports jammy-security/main arm64 Packages [365 kB]
Get:22 http://ports.ubuntu.com/ubuntu-ports jammy-security/main Translation-en [88.9 kB]
Get:23 http://ports.ubuntu.com/ubuntu-ports jammy-security/main arm64 DEP-11 Metadata [13.1 kB]
Get:24 http://ports.ubuntu.com/ubuntu-ports jammy-security/restricted arm64 Packages [139 kB]
Get:25 http://ports.ubuntu.com/ubuntu-ports jammy-security/restricted Translation-en [55.8 kB]
Get:26 http://ports.ubuntu.com/ubuntu-ports jammy-security/universe arm64 Packages [255 kB]
Get:27 http://ports.ubuntu.com/ubuntu-ports jammy-security/universe Translation-en [64.8 kB]
Get:28 http://ports.ubuntu.com/ubuntu-ports jammy-security/universe arm64 DEP-11 Metadata [12.1 kB]
Fetched 3224 kB in 8s (420 kB/s)                                               
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
14 packages can be upgraded. Run 'apt list --upgradable' to see them.
Hit:1 http://ports.ubuntu.com/ubuntu-ports jammy InRelease
Hit:2 http://ports.ubuntu.com/ubuntu-ports jammy-updates InRelease             
Hit:3 http://ppa.launchpad.net/ubuntu-xilinx/updates/ubuntu focal InRelease    
Hit:4 http://oem.archive.canonical.com/updates jammy-limerick InRelease        
Hit:5 http://ports.ubuntu.com/ubuntu-ports jammy-backports InRelease           
Hit:6 https://ppa.launchpadcontent.net/ubuntu-xilinx/sdk/ubuntu jammy InRelease
Hit:7 http://ports.ubuntu.com/ubuntu-ports jammy-security InRelease
Hit:8 https://ppa.launchpadcontent.net/xilinx-apps/ppa/ubuntu jammy InRelease
Reading package lists... Done                                  
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package python3.8-venv
E: Couldn't find any package by glob 'python3.8-venv'
E: Couldn't find any package by regex 'python3.8-venv'


sudo apt install python3.8-venv
を行っても”Couldn't find any package by glob 'python3.8-venv'”だった。

検索したところ、”GCEのUbuntu 20.04でvenvがaptでインストールできなかった原因と回避策”で、
sudo add-apt-repository universe
sudo apt update

するということでやってみたが、
sudo apt install python3.8-venv
すると同様にエラーだった。

仕方ないので、Ubuntu 22.04 は諦めて、以前作製した Ubuntu 20.04 の Kria-PYNQ で”kv260_median_platform のメディアン・フィルタを KV260 の Petalinux から動作させる21”を確かめてみよう。
  1. 2022年10月21日 05:02 |
  2. KRIA KV260 Vision AI Starter Kit
  3. | トラックバック:0
  4. | コメント:0

コメント

コメントの投稿


管理者にだけ表示を許可する

トラックバック URL
https://marsee101.blog.fc2.com/tb.php/5742-723775e8
この記事にトラックバックする(FC2ブログユーザー)